Hilfe Übersicht

RichTextEdi 1.3 Hilfe Übersicht

next

Hallo und Willkommen. Vielen Dank, dass Sie diese Software verwenden!

Mit RichTextEdi erhalten Sie einen leistungsstarken Textverarbeitungseditor anstelle eines Rich-Text-Editors. Nur in der Freeware-Version ist das hauptsächliche Speicherformat das Standard Rich-Text-Dateiformat (RTF).

RichTextEdi ist ein Rich-Text-Editor mit viel mehr Textverarbeitungsmöglichkeiten wie im bekannten WordPad® von Microsoft Windows®. Der Editor ist kompatibel zu den zuletzt von Microsoft® veröffentlichten RTF-Standards 1.9.1 (2008) und kann alle vorherigen Standards lesen. Die erstellten RTF-Dateien können mit allen Versionen von Microsoft Word® seit 1995 oder früher bis zu den neuesten gelesen und geöffnet werden.

Die meisten Textverarbeitungssoftware-Produkte unterstützen das RTF-Format beim Importieren und Exportieren und/oder direkten Bearbeiten, was es häufig zu einem "gemeinsamen" Format zwischen ansonsten inkompatibler Textverarbeitungssoftware und Betriebssystemen macht. So kann man Dateien mit (fast) allen Textverarbeitungsprogrammen auf dem Markt austauschen. Bemerkung: Die Vollversion kann zusätzlich Speichern und Bearbeiten für doc, docx und pdf Formate. Das RTF-Format von Word belegt viel Speicherplatz auf der Festplatte, das von WordPad weniger, aber kann nur wenig darstellen. RichTextEdi reduziert den erforderlichen Speicherplatz im Vergleich zu beiden beim RTF-Format, und bietet zusätzlich ein schnelles und komprimiertes Speicherformat. Dies ermöglicht einen schnellen Datenaustausch über das Internet.

Natürlich hat dieses Tool einen eigenen Stil, ein eigenes ästhetisches Erscheinungsbild und einige Funktionen, die bei anderen Editoren nicht vorhanden sind. RichTextEdi verfügt als Vollversion über einige zusätzliche Funktionen, die normalerweise nicht in Textverarbeitungstools enthalten sind, wie verschlüsselte und komprimierte Speicheroptionen. Die hohe Komprimierungsrate und schnelle Lade-/Speicherzeiten für komprimierte Dateien (eigenes Format) ist ein Plus für dieses Tool.

Auch wenn es sich um einen originellen und anders aussehenden Editor handelt, sind das Menü und die Schaltflächen für eine einfache Bedienung intuitiv und zusammen mit den Tastenkürzeln möglichst wie allgemein üblich und beispielsweise aus Microsoft-Anwendungen bekannt.

In den folgenden Kapiteln werden die Funktionalitäten von Menüs, Tastenkürzel und Tasten erläutert, und einige originelle Merkmale von RichTextEdi erwähnt. Enthält auch einen Anriss der vorhandenen für Textverarbeitung bekannten Funktionalitäten.

Nach dem Start könnte FrendSoft RichTextEdi so aussehen:

Oder so:

Oder so:

Im neuen Designmuster „Weiß“ (neutrales Format statt „kein Muster“):

Verwandte Begriffe:
System Anforderungen
Originelle Merkmale und Design
Textverarbeitungsfunktionen
Menüsteuerung
Schaltflächensteuerung
Tastenkürzel
Lizenzvereinbarung
Kontakt und Impressum

© seit 2015 FrendSoft®.


System Anforderungen

RichTextEdi 1.3 System Anforderungen

Hardware-Anforderungen:

� Pentium-CPU oder höher (486 nicht getestet)

� 256 MB RAM (alle aktuellen Betriebssysteme benötigen viel mehr). Wenn eine Komprimierung größerer Dateien erforderlich ist, wäre es gut, RAM hinzuzufügen, um die Zeit zu verkürzen. Aber der heutige Mindeststandard von 8 GB ist ohnehin ausreichend.

� 50 MB freier Festplattenspeicher, wenn .Net bereits installiert ist. .Net 4.0 oder höher wird benötigt, was etwa 140 MB bedeutet, wenn kein .Net davor installiert war. Meistens ist eine Version > 3.8 von .Net bereits Teil des Betriebssystems und auf Ihrem PC vorhanden

� Zusätzlich 30-40 MB, wenn die Microsoft Visual Studio-Laufzeitbibliothek oder Microsoft Visual Studio (in der passenden Version) nicht installiert sind. Sie können auswählen diese Bibliotheken auch zu installieren. Neuere Betriebssysteme (Windows 8 oder höher) installieren manchmal alle fehlenden Komponenten aus dem Netz.

� Insgesamt sind das dann meistens etwa 160 MB für die 32 Bit Version und 172 MB für die 64 Bit Version freier Speicherplatz, den man am Laufwerk benötigt.

Software-Anforderungen:

� RichTextEdi läuft in der 32-Bit-Version die Folgenden Microsoft Windows Plattformen: Windows XP, Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10 und möglicherweise andere Versionen. Da es auf .Net basiert, werden bisher nur Microsoft Windows-Betriebssysteme unterstützt. Die 32 Bit Version des Programms läuft im 32-Bit-Modus auch auf allen 64-Bit-Rechnern mit allen genannten Betriebssystemen.

� RichTextEdi läuft in der 64-Bit-Version auf den folgenden 64-Bit-Microsoft Windows-Plattformen: Windows 8, Windows 10, Windows 11 und möglicherweise andere Versionen. Da es auf .Net basiert, werden bisher nur Microsoft Windows-Betriebssysteme unterstützt.

� Die folgende Software muss auf Ihrem Computer installiert sein, damit FrendSoft RichTextEdi ordnungsgemäß ausgeführt werden kann:

� Microsoft Visual Studio Laufzeitbibliotheken Diese Software ist in den Installationsdateien von FrendSoft RichTextEdi enthalten.

� .Net in der passenden Version. Diese ist auch in den Installationsdateien vorhanden und kann zur Installation ausgewählt werden. Einige Installationen von Windows 8 und höher verwalten die Installation der entsprechenden Version aus dem Internet jedoch selbst.

Anmerkung: Microsoft und Microsoft Visual Studio sind eingetragene Warenzeichen der Microsoft Corporation.

Verwandte Begriffe:
Hilfe Übersicht
Originelle Merkmale und Design
Textverarbeitungsfunktionen
Menüsteuerung
Lizenzvereinbarung
Kontakt und Impressum


Originelle Merkmale und Design

RichTextEdi 1.3 Originelle Merkmale und Design

ÜDas originelle Design enthält ein Fensterhintergrundmuster, das als Rahmen sichtbar ist, wenn die Datei geöffnet ist, und in der Menüleiste. Die FREEWARE-Version enthält 9 Muster, von denen 3 nur Farbmuster sind: Schwarz, Weiß, Gold. Mit Schwarz und Weiß werden auch 2 schlichte Fenster-Outfits für Menschen angeboten, die keine Bildmuster oder Farben in Rahmen und Hintergrund wünschen. Die Bedienelemente passen sich dem gewählten Muster an.

ÜRahmen- und Hintergrundmuster können verwendet werden, um verschiedene Dateien in unterschiedlichen Designs auf dem Bildschirm anzuzeigen (die Anzahl der gleichzeitig angezeigten Dateien ist nicht wirklich begrenzt). Verschiedene Dateien oder Varianten gleichnamiger Dateien können so leichter unterschieden werden!

ÜEnthält ein komprimiertes Rich Text Speicherformat mit hoher Komprimierungsrate und schnellem Speichern und Laden. Das Laden der Datei erfolgt in der Regel schneller als bei der unkomprimierten Rich-Text-Datei.

ÜVerfügbare Formate (speichern und öffnen) sind Rich Text (rtf, wri), Text und Hypertext Markup Language (HTML). Dazu ein schnelles und komprimiertes Format (rtfq).

ÜWenn es geöffnet, aber nicht verwendet wird, verblasst das Programmfenster und wird später ikonisch. Es kann durch Klicken auf das Symbol erneut geöffnet werden. Diese Funktion kann bei Bedarf deaktiviert werden, und das Programm merkt sich diese Einstellung für den nächsten Start.

ÜEs erlaubt mehrere Einstellungen anzuzeigen und zu verändern, wie Kultur, Sprache, Kodierung. Kodierung wirkt nur auf Text-Dateien. Unabhängig voneinander können z.B. Datumsformate entsprechend einer Kultur eingefügt werden, während die Tastatur, und damit die Eingabesprache, auf eine von mehreren Sprachen dieser Kultur oder eine nicht zu dieser Kultur gebundene Sprache eingestellt ist. Praktisch z.B. für Länder oder Gebiete mit mehrsprachiger Bevölkerung.

ÜDie Schriftgröße kann von 2,5 bis 99,75 in vordefinierten oder beliebigen Schritten eingestellt werden (bei allem Respekt versuchen Sie dies mit WordPad, Microsoft Word oder anderen Programmen).

ÜEs gibt vordefinierte Schrift-/Hintergrundstile, die mit einfachen Klicks aus dem Menü ausgewählt werden können.

ÜDie meisten Einstellungen, auch wenn teilweise in der Datei gespeichert (wie Schriftarten und Stile usw.), werden beim Schließen des Programms gespeichert. Das heißt, man kann in weiten Bereichen individuell anpassen und diese Einstellungen werden gespeichert, um sie bei der nächsten Verwendung beim Start zur Verfügung zu haben. Wenn mehrere Instanzen geöffnet waren, so werden die Einstellungen des zuletzt geschlossenen Programm-Fensters gespeichert, inklusive des gewählten Designs.

ÜInsbesondere werden auch die Einstellungen für Kodierung, Sprache und Kultur gespeichert. So öffnet sich dieses Programm mit diesen Einstellungen, egal welche im Moment oder als Standard auf dem verwendeten Computer eingestellt sind. All diese Einstellungen lassen sich auch einfach und schnell an die aktuellen Bedürfnisse anpassen. Sprachangaben werden Bereichsgebunden auch in Dokumenten gespeichert. Diese Angabe kann man mit dem Kontextmenü der rechten Maustaste auslesen. Rechtschreibe - Korrektur stellt sich danach ein. Klickt man auf so einen Bereich wird diese Sprache nicht als Tastaturlayout eingestellt und die Statusleiste zeigt die gerade aktive Sprache der entsprechenden Instanz, welche zugleich auch Tastaturlayout ist. Nur mit dem Kontextmenü kann man diese Sprache sichtbar machen und als Tastaturlayout einstellen, wenn diese Sprache am PC installiert ist. Das Programm wird die Spracheinstellung als Tastatur-Layout setzen, und jedes Mal wenn man ein RichTextEdi Fenster schließt, wird das PC Standard Layout zurückgesetzt, welches sich die entsprechende Instanz gemerkt hatte. Jede RichTextEdi Instanz kann durch einfachen Klick auf eine Schaltfläche, zwischen 2 gemerkten Sprachen wechseln. Mehr darüber in Schaltflächensteuerung. Es ist einfacher zu verwenden als erklärt.

Bemerkung: In der Freeware-SW-Variante fehlen mehrere Optionen zur Dateikomprimierung und -verschlüsselung (einschließlich AES und RSA) und die Rechtschreibe-Korrektur.

Diese Funktionen ermöglichen einen vollständig angepassten Textverarbeitungs-Editor, unvergleichlich mehr als ein Rich-Text-Editor, mit einem außergewöhnlichen Design und praktischer Funktionalität. Auch einige weitere nutzbare Funktionen.

Verwandte Begriffe:
Hilfe Übersicht
System Anforderungen
Textverarbeitungsfunktionen
Beschreibung der Steuerelemente
Menüsteuerung
Tastenkürzel
Lizenzvereinbarung
Kontakt und Impressum


Textverarbeitungsfunktionen

RichTextEdi 1.3 Textverarbeitungsfunktionen

�Es können alle auf dem Computer installierten Schriftarten und alle damit verfügbaren Stile eingestellt und verwendet werden.

�Es können ganze Text- oder Absatzstile unter Wunschnamen gespeichert und aus einer Liste ausgewählt werden! Diese Stilformate werden mit der Datei gespeichert und stehen beim Öffnen zur Verfügung. Über den Menüpunkt <Format-->Text Formate> können diese Zeichen- oder Absatz- Wunschformate festgelegt werden.

�Zuletzt geöffnete Dateien werden in einer Liste gespeichert und können durch einfaches Klicken wieder geöffnet werden.

�Kopf- und Fußzeile verfügbar. In eingeschränkter Weise bei Verwendung von Vorlagen sogar 3 Kopfzeilen pro Abschnitt und mehrere Abschnitte pro Datei, wobei jeder Abschnitt ein eigenes Seitenformat hat. Die 3 Kopfzeilen sind erste Seite, gerade und ungerade. Die gesamte Kopf- / Fußzeile Funktionalität erweitert ein verwendetes Freeware Modul der TextControl GmbH legal, doch fehlt die Dynamik der Anpassung der Seitenränder - Anzeige an Kopf- / Fußzeilen Bereiche auch dann, wenn man über das Menü eine Kopf- oder Fußzeile hinzufügt. Der Anfangszustand ist so gewählt, dass es für die meisten Bedürfnisse passt. Die Vorlagen haben breitere bzw. anders gestaltete Kopf- und Fußzeilen. In der Vollversion sind diese Begrenzungen nicht vorhanden.

�Vordefinierte Texte wie Seitenzahl oder Anzahl der Seiten sind für Kopfzeile Fußzeile verfügbar. Viele, alle auf dem PC verfügbaren Datums- und Zeitformate, können verwendet werden, um Datum oder Zeit oder beides mit einem Klick einzufügen.

�Aufzählung, Nummerierung und strukturierte Nummerierung sind verfügbar.

�Tabellen und alle Funktionen zu Tabellen (in der Freeware-Version reduziert, aber nicht im möglichen Ergebnis).

�Layout innerhalb einer Seite im Dokument und Formatierung für Bilder.

�Hoch- und Tiefstellung, Einrückungen, Textrahmen, mehrere Spalten pro Seite etc.

�Hyperlinks, auf Text und auf Bilder.

�Markierten Text oder Inhalte separat speichern, Bilder aus RTF-Datei direkt in 5 verschiedenen Bildformaten speichern (Lesen von 7 Formaten: jpg, png, tiff, gif, emf, bmp, wmf).

�Einfügen nicht nur von Inhalten aus der Zwischenablage sondern auch ganzer Dateien und Bilder.

�Vollständige Such- und Ersetzungsmöglichkeiten.

�Vorlagen können gesetzt, in Themen strukturiert gespeichert und verwendet werden.

�Und einige mehr.

�Bemerkung: Die in der Freeware SW Variante fehlenden Funktionen wurden nicht erwähnt.

Diese Funktionen machen aus RichTextEdi einen Textverarbeitungs-Editor, unvergleichlich mehr als ein Rich-Text-Editor

Verwandte Begriffe:
Hilfe Übersicht
System Anforderungen
Originelle Merkmale und Design
Beschreibung der Steuerelemente
Menüsteuerung
Schaltflächensteuerung
Lizenzvereinbarung


Beschreibung der Steuerelemente

RichTextEdi 1.3 Beschreibung der Steuerelemente

Diese Software ist einfach zu bedienen, wie im Folgenden beschrieben:

  • Menüsteuerung
  • Schaltflächensteuerung

    • Einige Bemerkungen, Tipps und auch Restriktionen zur Freeware-Nutzung:

    • Beim Einfügen einer Datei werden die Hyperlinks aus dem Text nicht übernommen. Einige Textverarbeitende Programme erlauben gar nicht den Inhalt einer anderen Datei als Text direkt in die editierte Datei einzufügen, RichTextEdi bietet dieses, in der Freeware mit der Restriktion Hyperlinks.
    • Mit Format->Absatz kann man einen Rahmen um den Text setzen!
    • Spalte links einfügen funktioniert nicht, wenn die Einstellung auf Seitenanfang passt und die Seitenbreite bereits voll ist.
    • In der Freeware Version kann das Format einer Seite nur für die gesamte Datei angepasst werden.
    • Die Beschreibung der Schaltflächen und Menüs im Folgenden sind größtenteils auf die Freeware-Version beschränkt, der Sachverhalt wird jeweils erwähnt.
    • Es gibt ein kontextsensitives Kontext-Menü.

    Tipps und Tricks für die Verwendung mit Windows® (Gilt gesichert mindestens für Windows 10 und Windows 11. Die Windows Taste <WIN> ist ja inzwischen an allen Tastaturen.):

    • <WIN>+v öffnet die Zwischenablage als grafische Übersicht mehrerer Einträge. Daraus kann man durch Klick direkt ins Dokument einfügen. Bei Windows 11 sind Reiter (Tabs) auf der Benutzeroberfläche, über die man auch Emojis, Smilies, Kaomoji, Symbole oder sogar GIFs einfügen kann.
    • <WIN>+. öffnet in beiden Versionen nur diese Oberfläche über die man, wie vorher erwähnt, Emojis etc. einfügen kann. Bei Windows 10 sind es nur Symbole, Smilies und Kaomoji.
    • <WIN>+d leeren Desktop, alles wieder anzeigen, umschalten.
    • <WIN>+h öffnet eine Spracherkennungs- und Diktat Funktion, die Internet-Anschluss braucht. Damit kann man über die Stimme Text eingeben.
    • <WIN>+e öffnet eine neue Explorer Ansicht.
    • <WIN>+r öffnet das Ausführen Fenster.
    • <WIN>+i öffnet eine Benutzeroberfläche über die man persönliche Einstellungen machen kann.
    • <WIN>+p ermöglicht projizieren auf mehrere Desktops oder anderen Bildschirm oder eben angeschlossenen Projektor.

Verwandte Begriffe:
Originelle Merkmale und Design
Textverarbeitungsfunktionen
Menüsteuerung
Schaltflächensteuerung
Tastenkürzel


Menüsteuerung

RichTextEdi 1.3 Menüsteuerung

Beschreibung der Steuerelemente > Menüsteuerung

Das Menü von RichTextEdi sieht so aus:

Nachfolgend werden die Menüeinträge dargestellt und erklärt.

Das Datei Menü

Textdateien werden in der bei <Format-->Kodierung> gewählten Kodierung geöffnet und gespeichert.

<Druckvorschau> zeigt die zu druckenden Seiten, aber aus dem Druckvorschaumenü kann man nur gesamtes Dokument drucken auslösen. Man kann aus dem <Drucken> Menü mehrere Seiten, alle Seiten, aktuelle Seite oder einen markierten Bereich zum Drucken auswählen. Ebenfalls im Druckmenü auswählbar sind der Drucker oder das Druckprogramm und man kann dort die Druckereinstellungen ändern.

Detaillierte Seiteneinstellungen sind im Menü <Seite einrichten> möglich.

<Neu> erstellt eine neue Rich-Text-Datei. Diese kann später in verschiedenen Formaten gespeichert werden.

<Öffnen> kann Rich-Text-Dateien, Textdateien mit unterschiedlicher Kodierung und HTML-Dateien öffnen.

<Speichern unter...> kann die oben genannten Dateiformate mit verschiedenen Speicherformatoptionen speichern (siehe Menü Format). Durch Drucken mit einem (Freeware erhältlichen oder in Windows eingebauten) PDF-Dateidrucker kann man die Text-, Rich-Text- oder Html-Dateien auch als PDF speichern.

Mit <Markierung speichern unter> kann man einen ausgewählten Bereich aus der geöffneten Datei in einem gewünschten Format speichern.

Mit <Bild speichern unter> kann man ein Bild aus der geöffneten Datei in einem von 5 verschiedenen Formaten speichern (BMP, WMF, JPG, PNG, EMF).

Am Ende des Menüs Datei befindet sich eine Dropdown-Liste mit den zuletzt geöffneten Dateien. Diese Dateien werden beim Schließen des Programms gespeichert. Die Liste kann mit <Dateiliste löschen> gelöscht werden.

Man kann Dokumente als Vorlage speichern mit <Als Vorlage speichern> und mit einer Vorlage beginnen, wenn man ein neues Dokument erstellt. <Mit Vorlage beginnen> öffnet eine Liste mit Vorlagen und man kann eine durch einfaches Klicken auswählen. Um die Liste zu schließen, verwendet man die [ESC]-Taste. Alternativ kann man die rechte (oder als rechte Taste eingestellte) Maustaste drücken und <Abbrechen> wählen. Über das sich öffnende Menü kann man auch Listenelemente löschen oder umbenennen.
Um eine Sicherungskopie (Backup) für alle (inklusive eigene) Vorlagen zu machen, muss man das Verzeichnis RT_Templ aus dem eigenen Benutzerverzeichnis [Laufwerk:\Users\Benutzername\AppData\Local\] irgendwo sichern. Um dann diese Vorlagen wieder zu laden, muss man dieses gesicherte Verzeichnis unkomprimiert (also wie kopiert) in das Installationsverzeichnis laden und das Originalverzeichnis oder dessen Inhalt löschen. Bei einer Neuinstallation des PC wird dieses Benutzerverzeichnis immer gelöscht, es sei denn man sichert sowieso alles in der Cloud. Ist ein Fehler aufgetreten und die Vorlagen können nicht mehr geladen werden, so muss man einfach die Dateien TList.rtx und TLst.rtx aus dem besagten Verzeichnis RT_Templ löschen. Das Programm sichert dann die vorhandenen Vorlagen in ein Unterverzeichnis des Installationsverzeichnisses von FrendSoft RichTextEdi. Diese Dateien können dann als gewöhnliche Dateien geöffnet und wieder als Vorlage gespeichert werden. Legt man aber eine Sicherungskopie in das Installationsverzeichnis so wird diese zugleich geladen. Für diese Vorgänge neu laden oder importieren der Vorlagen kann es 2 Neustarts des Programms benötigen. Falls keine Neuinstallation des PC geschieht und nur RichTextEdi in die besagten Verzeichnisse schreibt, sollte es nie ein Problem geben. Man kann mehr als 16 000 Vorlagen speichern in mehr als 400 Themen gegliedert. Die mitgelieferten Vorlagen sind rudimentär und eher nur Beispiele. Nur einige erweitern die Funktionalität der FREEWARE.

Das Bearbeiten Menü

Der <Spezielles einfügen> Menüeintrag ermöglicht einfügen von einfachem oder formatiertem Text.

Die Such- und Ersetzungsalgorithmen sind schnell und einfach zu bedienen und erlauben alle allgemein üblichen und bekannten Einstellungen und Möglichkeiten. Man kann zwischen den Fenstern der Benutzeroberfläche zum Suchen und Ersetzen wechseln oder sie schließen, indem man das Kontextmenü mit einem rechten Mausklick auf die obere Titelleiste startet. Ein Doppelklick auf diese Balken schließt die Fenster.

Das Ansicht Menü

Dieses Menü ermöglicht das Umschalten zwischen verschiedenen Ansichten.

Man kann zwischen normaler oder Seitenansicht wählen, das verzögerte Ausblenden und Schließen zum Symbol, und die Sichtbarkeit von Steuerzeichen aktivieren oder deaktivieren. Bei Ansicht --> <Seitenansicht> kann man das Anzeigen der Seitenränder aktivieren oder deaktivieren.

<Gehe zu Seite> verschiebt den Fokus auf die ausgewählte Seite des geöffneten Dokuments und zeigt diese an.

<Gehe zu Zeile, Tabelle> öffnet ein Menü, in dem man direkt zu bestimmten Zeilen im Dokument springen oder einfach zur nächsten springen kann. Ebenso kann man zu einer Tabelle im Dokument wechseln oder einfach zur nächsten oder zur vorherigen zurückkehren. Schließen kann man dieses Menü durch Doppelklick oder rechte Maustaste und Schließen im Kontextmenü wählen.

<Design wechseln> ermöglicht das Umschalten zwischen verschiedenen Designs der Software. Das originelle Design kann Freude bei der Verwendung bereiten. Es hat mir Spaß gemacht, diesen Editor zu verwenden und zwischen Designs zu wechseln. Und verwenden Sie den Vorhang, wenn Sie möchten (siehe Lineal)!
Die Vorhang-Bemerkung bedeutet, dass, wenn man die Schaltfläche auf dem horizontalen oberen Lineal in der Ansicht ohne geöffnete Datei bis zum Ende zieht, das zu einer Änderung des Designs in dieser Gesamt-Hintergrund Ansicht führt. Neu in dieser Version ist, dass man dies mit der Schaltfläche unten links auf dem Bildschirm einfacher und schneller tun kann. Das bedeutet, dass in der Ansicht mit geöffneter Datei, durch Klicken auf die RT-Schaltfläche auch zum nächsten Design gewechselt wird.

Das Einfügen Menü

Die Menüs „Hyperlink hinzufügen“ und „Hyperlink bearbeiten“ sind ausgegraut, da nichts markiert ist. Die restlichen ausgegrauten Menüeinträge sind in der Freeware nicht verfügbar.

Es können alle auf dem PC verfügbaren Datums- und Zeitformate eingefügt werden. Diese können vorab ausgewählt werden, indem man eine Kultur aus dem Menü <Format -> Kultur> auswählt. Alle Formate können per Mausklick mit dem ersten Menüpunkt, <Datum (Format auswählen)>, eingefügt werden. Wie unten ersichtlich, stehen in der zweiten Menüposition spezielle Datums- und Zeitformate zur Verfügung. Außerdem ist es möglich, den Dateinamen oder / und den Pfad, in dem die Datei gespeichert ist, automatisch einzufügen.

Man kann eine Zeile oder einen Absatz einrücken / Einzug verkleinern.

Man kann einen Seitenumbruch einfügen.

Aufzählungszeichen, Nummerierungen und strukturierte Nummerierungen können, wie unten sichtbar, eingefügt werden:

Für das Einfügen von Kopf- oder / und Fußzeilen gibt es mehrere Möglichkeiten, wie unten ersichtlich. Man kann die Felder Anzahl der Seiten oder / und Seitenzahl automatisch in die Fußzeile oder Kopfzeile einfügen und man kann zwischen 2 Formaten für die Zahlen wählen. Oder man fügt einfach eine leere Kopfzeile, Fußzeile oder beides ein. Im Menü <Kopf- und Fußzeile> kann man auch die eingefügten oder bestehenden Kopfzeilen und Felder entfernen. Achtung: Diese Felder können nicht mit löschen entfernt werden.

In der ersten Ansicht unten sind die ausgegrauten Menüeinträge in der Freeware-Version nicht verfügbar, außer Entfernen, was ausgegraut ist, weil noch nichts eingefügt wurde.

In der zweiten Ansicht unten sieht man die Wahl des Zahlenformats.

Header / Footer Zahlenformat einfügen

In der dritten Ansicht unten wurde bereits eine Kopfzeile eingefügt und kann entfernt werden.

Mit <Einfügen->Bild> kann man verschiedene Bildformate direkt in den Dateiinhalt einfügen. Die unterstützten Formate sind: PNG, JPG, BMP, TIFF, GIF, EMF, WMF.

Mit <Einfügen->Datei> kann man den Inhalt einer Datei direkt in die geöffnete Datei einfügen, ohne sie zu öffnen. Die unterstützten Formate sind Textdateien und Rich-Text-Dateien.

<Einfügen->Hyperlink> fügt einen Link zum markierten Text oder Bild ein. Der Link kann ein Hyperlink oder ein Link zu einer Datei sein.

Das Format Menu

Alle Format Menü Einträge sind oben sichtbar. Das Menü Bild formatieren ist nur verfügbar, wenn ein Bild ausgewählt ist. Die anderen ausgegrauten Einträge sind nicht in der Freeware verfügbar. Die reduzierte Freeware-Seitenformatierung ist im Menü „Datei“ unter „Seite einrichten“ verfügbar.

ÜText Ausrichtung

Der erste Format Menüeintrag bezieht sich auf die horizontale und vertikale Ausrichtung der Schriftart, wie oben gezeigt. Diese Einstellungen können auch über die entsprechenden Schaltflächen manipuliert werden und die aktuelle Einstellung ist dort und im Menü markiert.

ÜFarben

Es kann eines aus den 4 vordefinierten Vorder- und Hintergrundfarbenpaaren ausgewählt werden oder es können die Farben direkt ausgewählt und bei Bedarf angepasst werden: Schriftfarbe, <Schrift Farbe> und Hintergrundfarbe, <Hintergrund Farbe>.

ÜSchrift

Man kann entweder <SchriftundFarben> vollständig anpassen oder 1 von 4 vordefinierten <Typ> (Schriftart), <Größe> oder <Stil> Varianten. Der Typ und die Größe können auch über eine Dropdown-Liste aus dem Schaltflächenmenü ausgewählt werden (siehe Kapitel "Schaltflächensteuerung"). Die Größe kann auch (schnell und einfach) in +/- 0,5 Schritten an die aktuellen Bedürfnisse angepasst werden, indem entsprechende Schaltflächen angeklickt werden (siehe Kapitel "Schaltflächensteuerung"). Die Stilvarianten sind unten sichtbar: normal, fett, kursiv, fett und kursiv, durchgestrichen und unterstrichen. Im vollständig benutzerdefinierten <SchriftundFarben> Menü, ist auch Doppelzeilenunterstreichung möglich.

ÜText Formate

Der Formatierungsstil erlaubt es, einen Absatzstil, insbesondere einen Schriftstil, zu definieren und unter einem gewünschten Namen zu speichern. Dieser Stil wird später im Rich-Text-Dokument gespeichert, wenn dies das gewählte Speicherformat ist. Alle für ein bestimmtes Dokument verfügbaren Stile sind in einem Dropdown-Menü auf der Schaltflächenleiste sichtbar und können von dort ausgewählt werden. Siehe auch "Schaltflächensteuerung". Es gibt vordefinierte Stile, wie den Standardstil "Normal" und andere, die verfügbar werden, z. B. beim Einfügen einer Kopf- oder Fußzeile etc. Die sich öffnende Oberfläche erlaubt verschiedene Einstellungen:

Als Absatz-Formatierungsstil kann auch eine Sprache festgelegt werden, egal ob sie auf dem PC installiert ist oder nicht (gilt für Grammatik-Prüfung und Keyboard (Tastatur) Sprache, wenn das jeweils installiert ist).

ÜSeite

Mit dem diesem Menüeintrag kann man direkt Seiten - Formatierungen ausführen. Es gibt 4 vorgefertigte Maße von Seitenrändern und die Möglichkeit direkt Quer- oder Hochformat für die Seite einzustellen. Bei <Seite Einrichten> öffnet man denselben Dialog wie bei <Datei>-><Seite Einrichten>. Absatzgebundene Seitenformate gibt es nur in der Vollversion.

ÜAbsatz

Mit dem <Absatz> Menüeintrag bei <Format> öffnet man einen Dialog, in dem alle Absatzeinstellungen geändert werden können.

Mit Format->Absatz kann man einen Rahmen um den Text legen!

ÜAufzählungszeichen und Nummerierung

Mit der Menüeintrag Option <Aufzählungszeichen und Nummerierung> bei Format öffnet man einen Dialog, in dem alle Einstellungen für Nummerierung oder Aufzählungszeichen geändert werden können.

ÜTabstopps

Mit dem <Tabstopps> Menüeintrag bei <Format> öffnet man einen Dialog, in dem verschiedene Arten von Tabstopps gesetzt oder gelöscht werden können.

ÜSpalten pro Seite

Es ist möglich, wie oben sichtbar, eine vordefinierte oder benutzerdefinierte Anzahl von Spalten pro Seite festzulegen.

ÜLineal

Hier ist es möglich, die Einheit für das vertikale und horizontale Lineal zwischen cm (mm) und Zoll umzuschalten oder ein anderes Lineal mit der Einheit Punkte auszuwählen. Dieses Lineal ist nicht wie die anderen beiden für den Dauereinsatz gedacht, sondern misst in Schritten von 5 Bildschirmpunkten / Pixeln. Das kann verwendet werden, um die Bildschirmauflösung zu messen und Ansichten zu verbessern. Die Auflösung in der Datei bezieht sich ohnehin auf das Druckformat. Wenn die Datei geschlossen wird, ist dieses Punkte-Lineal immer sichtbar und hat eine andere Verwendung. Es ist nur horizontal verfÃ¼gbar.

Klickt man auf ein Lineal, wird eine Gerade waagerecht oder senkrecht Ã¼ber die ganze FlÃ¤che des Dokumentes angezeigt. So kann man Ansichten besser konfigurieren und Tabstopps genauer setzen. Will man Tabstopps setzen und die senkrechte Linie zeigt eine ungewollte Position, so muss man die Maus auÃŸerhalb des Lineals wieder freilassen, damit kein Tabstopp gesetzt wird (einfach leicht nach oben oder unten ziehen).

ÜKultur

Auswählbar sind aus einer Dropdown-Liste alle auf dem Rechner verfügbaren Kulturen. Der Kultursatz wird gespeichert und RichTextEdi wird bei der nächsten Verwendung mit demselben Kultursatz gestartet. So können Sie beispielsweise RichTextEdi mit einer anderen Kultur als dem Standard auf dem verwendeten Rechner verwenden. Die Kultureinstellung ist unabhängig von der Spracheinstellung. Von der Kultureinstellung hängt das Datums- und Zeitstempelformat ab, das von <Einfügen Datum+Zeit> oder ähnlichen Menüeinträgen verwendet wird. Wenn eine Kultur an eine „von rechts nach links“-Sprache gebunden ist, wechselt der Editor in das „von rechts nach links“-Format. Dasselbe gilt, wenn eine entsprechende Sprache ausgewählt wird.

ÜCodierung

Wie gezeigt, kann eine der verfügbaren Kodierungen wie Unicode, ANSI oder UTF-8 ausgewählt werden. US-ASCII ist ein alter Standard und für einfachen englischen Text und viele Anwendungen immer noch sehr gut geeignet. Beim Ändern der Kodierung wird die Datei in der gewählten Kodierung geladen und gespeichert. Einige Zeichen werden in bestimmten Codierungen nicht dargestellt, da die zugehörige Zahl in dieser Codierung keine Darstellung hat. Es ist am besten, in Unicode zu speichern, damit die meisten Editoren den Text anzeigen können. Man kann RichTextEdi auch verwenden, um mit einer bestimmten Kodierung zu öffnen und mit einer anderen zu speichern. Die hier umschaltbare Codierung wirkt sich nur auf Dateien im Text-Format aus.

ÜSprache

Aus einer Dropdown-Liste kann man eine der auf dem PC installierten Sprachen auswählen. Es können nur bereits installierte Sprachen ausgewählt werden. Wenn die SPC-Schaltfläche doppelt betätigt wurde (grün, durch 2x oder Doppelklick) dann wird die gewählte Sprache in der entsprechenden Programm-Instanz als PC Standard gespeichert, wenn nicht, mit der SRT-Schaltfläche verbunden. In jedem Fall gilt diese Auswahl als Eingabesprache im Dokument ab Cursorposition und das Tastatur-Layout wird entsprechend gesetzt. Die Sprache, die beim Bearbeiten des Dokumentes angewendet wird, entspricht der aktivierten Schaltfläche (gelb) SPC oder SRT. Mehr darüber bei Schaltflächensteuerung. Das Dokument kann mehrere Sprachbereiche haben, das können einzelne Wörter, Absätze, ganze Seiten sein, die in der Datei des Dokumentes gespeichert werden. Mit der rechten Maustaste kann man die im Kontext-Menü sichtbar machen und durch einen Klick als SRT Sprache auswÃ¤hlen, wenn diese Sprache am PC installiert ist. Es wird dann automatisch die SRT-Taste aktiviert. Wenn mehrere RichTextEdi-Fenster geöffnet sind, wird durch Klicken in das geöffnete Dokument direkt die aktive Sprache dieser Instanz als Tastatur-Layout gesetzt.

ÜBild

<Format-->Bild> öffnet ein Dialogfeld mit 3 Registerkarten, wie oben sichtbar. Nur wenn ein Bild angeklickt, aktiviert oder markiert wird, kann dieses Dialogfeld geöffnet werden.

Das Tabelle Menü

Das <Tabelle> Menü ermöglicht alle notwendigen Aktionen für Design, Erstellung und Konfiguration von Tabellen. Einige ausgegraute Menüeinträge sind in der Freeware-Version nicht verfügbar, was jedoch das mögliche Ergebnis nicht schmälert, sondern lediglich die Erreichbarkeit etwas erschwert. Dies gilt auch für folgende Ansichten zum Tabellenmenü.

Die erste Menüposition ermöglicht das Einfügen entweder einer ganzen Tabelle oder Zeilen und Spalten, wie im Bild unten zu sehen. Man kann auch mit Strg+v Zeilen unten hinzufügen, die man vorher mit Strg+c kopiert hatte, doch darf nichts markiert sein, wenn man hinzufügt, nur um die Zeile zu kopieren muss man die ganz markieren. Wählt man "mit Kopfzeile" beim Einfügen einer Tabelle, wiederholt sich die erste Zeile auf jeder Seite und ist nur am Anfang schreibbar.

Tabelle: Zeile einfügen Tabelle: Zeile einfügen

Der <Auswählen> Menüeintrag ermöglicht die einfache Auswahl von Teilen oder einer ganzen Tabelle.

Ähnlich wie beim Auswählen kann der Menüeintrag <Löschen> das Löschen einer ganzen Tabelle oder nur Teilen davon, abhängig von der/den ausgewählten Tabellenzelle(n) ermöglichen.

In den folgenden 2 Menüeinträgen ist es möglich, Zellen zu teilen oder zu verbinden. Um Zellen zu verbinden, muss man die zu verbindenden Zellen auswählen. Teilen (Split) funktioniert nur wenn man auf schon verbundene Zellen klickt.

Die Gitterlinien, die jede Zelle markieren, können aktiviert oder deaktiviert werden.

Mit <Format> öffnet man einen Dialog, in dem es möglich ist, verschiedene Formatelemente für die Tabelle einzustellen. Man setzt die sogenannten Tabelleneigenschaften! Markiert man einen Teil der Tabelle, dann gilt das eingestellte Format nur für diesen Teil. Stellt man das Format für die ganze Tabelle ein, so kann man mit der Auswahl "Gleiche Kopfzeile auf jeder Seite wiederholen" auch hier eine Kopfzeile festlegen. Je nachdem in welcher Zeile der Cursor dabei war, kann man dadurch auch weitere Zeilen als Kopfzeilen markieren. Bedingung: Jede solche weiter Kopfzeile darf über sich nur festgelegte Kopfzeilen haben, sonst wird der Eintrag ignoriert.

<Spaltenbreite> ermöglicht die Festlegung der Breite für eine ausgewählte oder alle Spalten einer Tabelle. Dies ist manchmal notwendig, wenn die Tabelle nicht vollständig auf der Seite ist, und ist einfacher als das Ändern durch Ziehen mit der Maus. Die Zeilenhöhe wird automatisch unter Berücksichtigung der Anforderungen eingestellt.

Das Extras Menü

Extras bezieht sich auf eine Reihe von Dateikomprimierungs-/-dekomprimierungs- und Dateiverschlüsselungs-/-entschlüsselungswerkzeugen, die auf die in den Editor geladene Datei oder zum Laden einer Datei in den Editor oder auf beliebige Dateien anwendbar sind. Alle diese Dateibearbeitungsmethoden und -algorithmen entsprechen bekannten Standards. In der Freeware-Version sind für bearbeitete Dateien nur das komprimierte Öffnen und das komprimierte Speichern möglich.

Trotzdem gilt für FrendSoft RichTextEdi, dass es auch in der Freeware-Version viele Funktionen bietet, die eine gute Textverarbeitung und einige zusätzliche Funktionen ermöglichen.

Das Hilfe Menü

Durch Klicken auf <Hilfe> zeigt das Windows-Hilfetool diese Hilfedatei an.

Klicken auf <Anzeigeeinstellungen> zeigt eine Reihe aktueller Einstellungen, die auf dem verwendeten PC und für das gestartete Programm RichTextEdi gültig sind.

Klicken auf <Über> öffnet die Oberfläche:

Verwandte Begriffe:
Hilfe Übersicht
System Anforderungen
Originelle Merkmale und Design
Textverarbeitungsfunktionen
Beschreibung der Steuerelemente
Schaltflächensteuerung
Tastenkürzel
Lizenzvereinbarung
Kontakt und Impressum


Schaltflächensteuerung

RichTextEdi 1.3 Schaltflächensteuerung

Beschreibung der Steuerelemente > Schaltflächensteuerung

Die Menüleiste der Schaltflächen enthält die folgenden Elemente:

Erste Zeile von links nach rechts:

ÜSchaltfläche „Datei öffnen“

ÜSchaltfläche „Neue Datei“

ÜKopieren

ÜAusschneiden

ÜEinfügen

ÜDatei speichern

ÜRückgängig

ÜWiederherstellen

ÜDropdown-Liste Auswahl Schriftart

ÜFeld Schriftgrad

In dieses Feld können Sie die Größe (Schriftgrad) manuell eingeben, indem Sie eine gültige Ganzzahl zwischen 3 und 99 oder eine gültige reelle Zahl zwischen 2,5 und 99,75 eingeben. Das Format ist xx.yy, während der Punkt (oder Komma) und yy fehlen können.

ÜDropdown-Liste Auswahl Schriftgrad

Entweder sieht man die Dropdown-Liste oder die + / - Schaltflächen. Zum Anpassen können Sie in das Größenfeld klicken oder das Dropdown verwenden.

ÜTasten - und + zum Ändern der Schriftgröße in 0,5-Schritten nach oben und unten (schnell und einfach)

ÜAufzählungszeichen

ÜNummerierung

ÜStrukturierte Nummerierung

ÜTextausrichtung links

ÜTextausrichtung Mitte

ÜTextausrichtung rechts

ÜTextausrichtung Blocksatz

ÜEinzug verkleinern

ÜEinzug vergrößern

ÜDiese Hilfe starten

ÜSchaltfläche „Datei schließen“

Zweite Zeile von links nach rechts:

ÜDropdown-Liste Formatvorlagen

Einige Formatvorlagen sind vordefiniert und erscheinen automatisch beim Einstellen von Kopf- und Fußzeile usw. Man kann eigene Formatvorlagen definieren, die dann in der Datei oder den Vorlagen gespeichert werden. Man kann Formatvorlagen für Titel, Inhaltsverzeichnis und viele andere Zwecke festlegen.

ÜFestlegen / Zurücksetzen der Schriftart fett

ÜFestlegen / Zurücksetzen der Schriftart kursiv

ÜFestlegen / Zurücksetzen der Schriftart unterstrichen

ÜFestlegen / Zurücksetzen der Schriftart durchgestrichen

ÜTiefgestellt

ÜHochgestellt

ÜUmschalten Tabulator Modus

Durch Klicken auf diese Schaltfläche wird der Tabulator-Einstellungsmodus zwischen links, rechts, Mitte, Fließkomma Mitte (Tab kann auch in Zwischenpositionen zwischen die kleinsten Linealmarkierungen gesetzt werden) und Löschen umgeschaltet. Der eingestellte Modus erscheint bezogen auf die folgenden 3 TAB-Modustasten als gedrückte Taste. Wenn keine Taste gedrückt wird, sind die beiden anderen Modi eingestellt. Wenn Sie bei gesetztem Löschmodus in das horizontale Lineal klicken, werden alle rechts vom Klickpunkt sichtbaren Tabulatorpositionen gelöscht.

ÜTabulator Modus links

ÜTabulator Modus Mitte

ÜTabulator Modus rechts

ÜSteuerzeichen ein-/ausblenden

ÜSRT Umschalten der Tastatur auf die in der aktuellen Instanz von RichTextEdi mit der SRT-Schaltfläche verbundene Sprache (Tastaturlayout)

Durch Klicken auf diese Schaltfläche wird die Tastatur auf die daran gebundene Spracheneinstellung von RichTextEdi umgeschaltet und ein Farbwechsel der Schaltfläche zeigt an, dass sie aktiv ist. Texteingaben werden mit diesem Sprachattribut in der Datei gespeichert, das beim erneuten Öffnen der Datei erkannt wird (dies ist RTF-Standard und diese Bereiche werden auch von anderen Programmen wie Microsoft Word® erkannt) und für die Rechtschreibprüfung verwendet oder mit Hilfe des Kontexts-Menüs zum Festlegen dieser Sprache als Tastaturlayout (dies ist RichTextEdi-spezifisch). In einer Datei können entsprechend mehrere Sprachbereiche gespeichert werden. Mit der Dropdown-Liste „Format – Sprache“ kann jederzeit zu einer der auf dem PC installierten Sprachen gewechselt werden. Diese Sprache wird mit der SRT Taste verbunden und diese aktiviert, wenn nicht der Modus Setzen der SPC Sprache (SPC Taste grün) aktiv war. Die SRT Sprach-Einstellung wird beim Start des Programm-Fensters aus der einzigen Einstellungsdatei gelesen. Erinnerung: Für alle Instanzen gibt es nur eine einzige Einstellungsdatei. Wenn jedoch mehrere Instanzen geöffnet sind, kann jede davon unabhängig von den anderen RichTextEdi-Instanzen zwei verschiedene Sprachen speichern und zwischen ihnen mit einfachem Klick wechseln. Die in einem geöffneten Dokument aktive Sprache wird als Tastatur-Layout festgelegt, wenn dieses Dokument per Mausklick aktiviert wird. Beim Schließen des Fensters (nicht beim bloßen Schließen des Dokuments) wird die in dieser Instanz bekannte Standardsprache als Tastatur-Layout eingestellt. Dies ist die Sprache, die beim Öffnen dieser Instanz (Programm-Fenster) aus den Einstellungen gelesen oder während der Verwendung mit der SPC-Taste gezielt eingestellt wurde. Durch das Schließen der Instanz werden alle Einstellungen in der einzigen Einstellungsdatei gespeichert.

ÜSPC Umschalten der Tastatur auf die in der aktiven RichTextEdi-Instanz gespeicherte PC-Standardsprache (Tastaturlayout)

Durch Klicken auf diese Schaltfläche wird die Tastatur auf die PC-Standardsprache, die im aktiven RichTextEdi-Fenster gespeichert ist, umgeschaltet, und ein Farbwechsel der Schaltfläche zeigt an, dass sie aktiv ist. Texteingaben werden mit diesem Sprachattribut in der Datei gespeichert, das beim erneuten Öffnen der Datei erkannt wird (dies ist RTF-Standard und diese Bereiche werden auch von anderen Programmen wie Microsoft Word® erkannt) und für die Rechtschreibprüfung verwendet oder mit Hilfe des Kontexts-Menüs zum Festlegen dieser Sprache als Tastaturlayout (dies ist RichTextEdi-spezifisch). In einer Datei können entsprechend mehrere Sprachbereiche gespeichert werden. Zweimaliges Klicken aktiviert das Setzen der an die SPC-Schaltfläche gebundene Sprache (Schaltflächenfarbe grün) und diese Schaltfläche bleibt aktiv. Wenn die Schaltfläche diese grüne Farbe hat, kann man mit dem Dropdown-Menü „Format – Sprache“ jederzeit zu einer der auf dem PC installierten Sprachen wechseln und stellt so die in diesem Fenster bekannte PC-Standardsprache ein, die sonst beim ersten Programmstart eingestellt oder, bei weiteren Starts, aus der einzigen Einstellungsdatei eingelesen wird. Der Einstellungsmodus endet automatisch, nachdem im Dropdown-Menü „Format – Sprache“ eine Sprache eingestellt wurde. Um den Einstellungsmodus zu beenden, kann man auch auf die Schaltfläche SRT klicken, wodurch die andere RichTextEdi-Auswahlsprache dieses Programmfensters aktiviert wird. Erinnerung: Für alle Instanzen gibt es nur eine einzige Einstellungsdatei. Wenn jedoch mehrere Instanzen geöffnet sind, kann jede davon unabhängig von den anderen RichTextEdi-Instanzen zwei verschiedene Sprachen speichern und zwischen ihnen mit einfachem Klick wechseln. Die in einem geöffneten Dokument aktive Sprache wird als Tastatur-Layout festgelegt, wenn dieses Dokument per Mausklick aktiviert wird. Beim Schließen des Fensters (nicht beim bloßen Schließen des Dokuments) wird die in dieser Instanz bekannte Standardsprache als Tastatur-Layout eingestellt. Durch das Schließen der Instanz werden alle Einstellungen in der einzigen Einstellungsdatei gespeichert.

Verwandte Begriffe:
Hilfe Übersicht
Textverarbeitungsfunktionen
Beschreibung der Steuerelemente
Menüsteuerung


Tastenkürzel

RichTextEdi 1.3 Tastenkürzel

Beschreibung der Steuerelemente > Tastenkürzel

Die Shortcuts (Tastenkürzel) sind entweder im Menü sichtbar oder werden durch Drücken der „Alt“-Taste sichtbar. Man kann bekannte Tastenkürzel wie Strg+c zum Kopieren, Strg+v zum Einfügen und Strg+x zum Ausschneiden verwenden.

Verknüpfungen erscheinen für die Menüs <Datei> und <Bearbeiten> wie unten ersichtlich.

Weitere Tastenkürzel und Bemerkungen:

  • Mit Strg+g kann man "Gehe zu Seitennummer" aus dem Menü <Ansicht> starten.
  • Drucken kann auch mit Strg+p gestartet werden.
  • Mit Strg+i kann man innerhalb von Tabellen-Zellen einen Vorschub erzielen wie mit der TAB-Taste außerhalb. Mit der Tab-Taste springt man innerhalb der Tabellen von Zelle zu Zelle. Außerhalb von Tabellen funktioniert Strg+i wie die TAB-Taste.

Verwandte Begriffe:
Hilfe Übersicht
Originelle Merkmale und Design
Beschreibung der Steuerelemente


Lizenzvereinbarung

RichTextEdi 1.3 Lizenzvereinbarung

Dies ist eine rechtsverbindliche Vereinbarung zwischen dem Benutzer (der als Lizenznehmer genannt wird) und FrendSoft (Lizenzgebers genannt). Durch die Installation und/oder Verwendung dieses hierin bereitgestellten Softwareprogramms und anderer damit verbundener Materialien (im Folgenden als Software bezeichnet) akzeptiert der Lizenznehmer die nachstehenden Bedingungen.

Dies ist die Lizenzvereinbarung der Freeware-Version!

Lizenzerteilung: FrendSoft® gewährt dem Lizenznehmer ein nicht ausschließliches Recht zur Nutzung dieser Software gemäß den in dieser Vereinbarung enthaltenen Bedingungen.

Freeware: Dies ist die Freeware-Version von RichTextEdi. Die Nutzung ist gebührenfrei möglich. Diese Editor-Version soll Freeware bleiben. Wenn der Lizenznehmer der Meinung ist, dass die Programmierer eine finanzielle Aufmerksamkeit verdienen, sehen Sie sich "Kontakt und Impressum" an. Oder Sie überweisen Geld auf folgendes Konto: IBAN DE58502205000008416919, BIC BOFSDEF1XXX Bank Of Scotland! Freeware wird besser durch Ihre Spende! Sicherlich gibt es einige Funktionen, die als Freeware nicht verfügbar sind, wie Dateiverschlüsselung und einige Möglichkeiten der Dateikomprimierung, auch einige andere Funktionen sind eingeschränkt. Sorry, aber erstens war der Aufwand für die gesamte Software wirklich immens und wir haben noch keinen finanziellen Ausgleich und zweitens müssen einige Sicherheitsalgorithmen wie Verschlüsselung geschützt werden. Auch volle Textverarbeitungsfunktionalität ist nur in der Vollversion vorhanden. Migration auf andere Plattformen als nur Microsoft Windows und .Net wäre möglich und ist geplant.

Gültigkeit und Versionen: Diese Vereinbarung gilt nur für die gelieferte Version. Jede andere Version enthält ihre eigene Lizenzvereinbarung. Die Software darf nicht verändert, sondern nur im gelieferten Zustand verwendet werden.

Kopien: Der Lizenznehmer kann eine unbegrenzte Anzahl von Kopien der Freeware-Version erstellen.

Übertragung an andere Benutzer: Will der Lizenznehmer die Software auf andere Nutzer übertragen, so ist dies nur unter Einbeziehung dieser Lizenzvereinbarung zulässig. Der Lizenznehmer darf diese Software nicht modifizieren, sondern nur so verwenden, wie sie ist. Es ist nicht gestattet, modifizierte Kopien dieser Software an andere Benutzer zu übertragen. Diese Software darf nicht entgeltlich weitergegeben werden, sondern nur als Freeware. Sehr geehrter Lizenznehmer, bitte teilen Sie anderen Benutzern mit, wo Sie diese Software herunterladen können, anstatt sie selbst weiterzugeben.

Quellcode-Eigentum: Der Quellcode dieser Software und alle zugehörigen Dateien sind Eigentum von FrendSoft® und den Besitzern dieser Marke und Firma, welche die Eigentumsrechte am Quellcode, seinen Kopien, Modifikationen oder zusammengeführten Teilen behalten. Das Zusammenführen dieser Software mit anderen Programmen ist möglicherweise nur ausnahmsweise unter Berücksichtigung einer zusätzlichen Vereinbarung zulässig, sofern diese von FrendSoft® erteilt wird. Es ist nicht gestattet, den Quellcode aus den gelieferten Softwaredateien zu extrahieren oder neu zu erstellen.

Haftungsausschluss: FrendSoft® schließt alle ausdrücklichen oder stillschweigenden Garantien aus, einschließlich, aber nicht beschränkt auf stillschweigende Garantien der Marktgängigkeit, Eignung für einen bestimmten Zweck und Nichtverletzung.

Haftungsausschluss anderer Module: FrendSoft® verwendet für RichTextEdi Software von Dritten, die darum bitten, einen Haftungsausschluss und eine Lizenzvereinbarung für ihre Software in der Dokumentation von RichTextEdi, das ist diese Hilfe - Datei, zu platzieren.

Dieses ist hier enthalten!

Haftungsausschluss anderer Anbieter:

*-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------*

* Copyright (c) 2003-2006 Marcus Geelnard

This software is provided 'as-is', without any express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software. If you use this software in a product, an acknowledgment in the

product documentation would be appreciated but is not required. FrendSoft®: Wir haben Teile dieses Codes verwendet, aber angepasst!

2. Altered source versions must be plainly marked as such, and must not be misrepresented as being the original software.

3. This notice may not be removed or altered from any source distribution.

Marcus Geelnard

*-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------*

Die Lizenzvereinbarung von FrendSoft® RichTextEdi ist konform zu Softwarelizenzen von Drittsoftware.

In der FREEWARE-Version enthält RichTextEdi auch die Freeware-Version von TxTextControl der TextControl GmbH. Die angebotenen Funktionalitäten wurden von FrendSoft auf legale Weise erweitert (gemäß „TX TEXT CONTROL EXPRESS NON-COMMERCIAL LICENSE AGREEMENT“). Vielen Dank für die Unterstützung!

Verwandte Begriffe:
Hilfe Übersicht
System Anforderungen
Originelle Merkmale und Design
Textverarbeitungsfunktionen
Menüsteuerung
Schaltflächensteuerung
Tastenkürzel
Kontakt und Impressum


Kontakt und Impressum

RichTextEdi 1.3 Kontakt und Impressum

previous

Sehr geehrter Benutzer oder Lizenznehmer

Wenn Sie uns kontaktieren möchten, können Sie die Website besuchen: http://www.frendsoft.de

Zur Realisierung dieses Programms haben SW-Experten und Programmierer bei FrendSoft beigetragen.

Sie können uns direkt per E-Mail kontaktieren: contact@frendsoft.de. Es steht Ihnen frei, uns etwas Geld für unsere Arbeit zu schicken:

Bankkonto: IBAN DE58502205000008416919, BIC BOFSDEF1XXX Bank Of Scotland!

FrendSoft: Leichteres Leben durch sinnvolle Software! FrendSoft unterstützt: Respektvolles Miteinander und Freundschaft!

Vielen Dank fürs Lesen und für Ihr Interesse. Wir hoffen, dass es für Sie irgendwie nützlich war!

Verwandte Begriffe:
Hilfe Übersicht
System Anforderungen
Originelle Merkmale und Design