Hilfe übersicht

TextEdi 1. Hilfe: Übersicht

next

Hallo und willkommen. Danke für die Verwendung dieser Software!

TextEdi ist ein simpler Text Editor vergleichbar mit Microsoft Windows Notepad und vielen anderen Programmen, die im Netz oder am Markt zu haben sind.

Sicher hat dieses Tool einen eigenen Stil, eigene Ästhetik und Aussehen und einige eigene Features, die vergleichbare Programme meist nicht haben.

Auch wenn originell und besonders aussehend, wurden für erleichterte Verwendung die Menüeinträge, Schaltflächen und Tastenkombinationen so gewählt, dass sie intuitiv und wenn möglich gleich sind wie die schon aus anderen Programmen, z.B. von Microsoft bekannten.

In den nächsten Kapiteln werden die Funktionen der Menüs, Tastenkombinationen (Tastenkürzel) und Schaltflächen erklärt und einige originelle Features von TextEdi aufgezählt.

Wenn gestartet, könnte FrendSoft TextEdi so aussehen:

Oder so:

Ähnliche Themen:
Originelle Features und Design
Verwendung und Steuerelemente
Das Menü
Lizenzvereinbarung

© 2013-2014 FrendSoft.


2. System Anforderungen

TextEdi 2. System Anforderungen

Hardware Anforderungen:

ÜPentium CPU oder höher (486 nicht getestet)
Ü128 MB RAM.
Ü 3,9 MB freier Festplatten-Speicher, wenn .Net schon installiert ist.

Ü 28 MB freier Festplatten-Speicher, wenn .Net 2.0 SP2 auch installiert werden soll. Mindestens diese Version von .Net ist notwendig, damit die Software TextEdi 1.2 laufen kann. ACHTUNG: .Net 3.0 ist auch nicht kompatibel, dafür aber .Net3.0 SP1 und höher. Microsoft .Net2.0 SP2 wird nicht installiert, wenn bereits diese oder eine höhere Version installiert ist (aber das Programm wird mit der Version funktionieren). Ältere Betriebssysteme wie Windows 98 oder Windows 2000, welche die .Net Installation nicht akzeptieren und auch keine höhere Version installiert haben, sind ungeeignet für TextEdi.

Ü 201 MB freier Festplatten-Speicher, wenn .Net 3.5 auch installiert werden soll. ACHTUNG: .Net 3.5 wird nicht installiert, wenn bereits eine neuere Version von .Net installiert ist (aber das Programm wird mit der Version funktionieren). Ältere Betriebssysteme wie Windows 98 oder Windows 2000, welche die .Net Installation nicht akzeptieren und auch keine höhere Version installiert haben, sind ungeeignet für TextEdi.

Ü Zusätzlich 1,8 MB wenn die Runtime Bibliothek von Microsoft Visual Studio oder Microsoft Visual Studio nicht installiert sind. Jede Installer Version erlaubt auch die Installation der Runtime Bibliotheken von Microsoft Visual Studio.

Ü Zusätzlich 1,7 bis 3,0 MB, abhängig vom Betriebssystem, wenn der Windows Installer Version 3.1 oder höher nicht am System installiert ist. Jeder Installer, der auch eine .Net Version neben TextEdi selbst enthält, erlaubt die zusätzliche Installation des aktuellsten Windows Installer 4.5. Mindestens die Version 3.1 des Windows Installer wird benötigt, um Microsoft .Net installieren zu können.

Ü 205,9 MB Festplatten-Speicher werden maximal benötigt, wenn man den Windows Installer 4.5, .Net 3.5, VCRediStart (Microsoft Visual Studio Runtime Bibliotheken) und natürlich FrendSoft TextEdi 1.2, installiert.

Software Anforderungen:

Ü TextEdi läuft auf folgenden 32-Bit Microsoft Windows Versionen: Windows XP, Windows Vista, Windows 7, Windows 8 und vielleicht auch andere. Weil TextEdi auf .Net basiert, kommen nur Microsoft Windows Betriebssysteme für TextEdi in Frage. Das Programm läuft im 32 Bit Modus auch auf allen 64 Bit Maschinen und mit allen erwähnten Betriebssystemen, auch wenn diese 64-Bit Systeme sind!

ÜDie folgende Software muss auf dem Computer installiert sein, damit FrendSoft TextEdi richtig funktionieren kann: (diese gesamte Software ist in einigen der TextEdi Installer vorhanden und kann installiert werden):

Ü Microsoft Visual Studio Runtime Bibliotheken

Ü .Net 2.0 SP2 oder höher (es gibt Installer die .Net 2.0 SP2 enthalten und andere die .Net 3.5 mit installieren können, aber das benötigt mehr Speicherplatz). Um .Net installieren zu können benötigt man den Windows Installer 3.1 oder höher. Die Installer die eine Version von .Net enthalten installieren wenn gewünscht gleichzeitig den Windows Installer 4.5 der mit Windows XP and allen höheren Microsoft Betriebssystemen läuft.

Bemerkung: Microsoft und Microsoft Visual Studio sind eingetragene Marken von Microsoft Corporation.


3. Originelle Features und Design

TextEdi 3. Originelle Features und Design

ÜDas originelle Design beinhaltet ein Hintergrundbild in Menü und Fenster.
ÜWenn geöffnet aber nicht verwendet, wird das Programmfenster durchsichtig und später wird es zu einem Symbol in der Taskleiste reduziert. Man kann durch Klick auf dieses Symbol das Programmfenster wieder öffnen.
ÜEs kann mehrere aktuell am PC und für das Programm geltende Einstellungen anzeigen, wie Kultur, Sprache, Codierung.
ÜAlle Schriften, Schrift- und Hintergrundfarben, die am PC vorhanden sind, können ausgewählt werden.
ÜAlle für diese Schriften vorhandenen Stile können ausgewählt werden.
ÜDie Schriftgröße kann von 2,5 bis 99,75 ausgewählt werden. Die Schriftgröße kann auch in 0,5 Schritten mit zwei Schaltflächen + und - verändert werden.
ÜSchriftstile fett und kursiv können mit Schaltflächen ein- und ausgeschaltet werden.
ÜEs gibt vordefinierte Schrift / Hintergrund Kombinationen die man mit einfachen Klicks aus dem Menü wählen kann.
ÜAlle Einstellungen werden beim Schließen des Programms gespeichert. Das heißt man kann Größe und Aspekt des Editors in weitem Rahmen anpassen und diese Einstellungen bleiben für folgende Verwendung erhalten.
ÜEs werden insbesondere auch die Einstellungen für Codierung, Sprache und Kultur gespeichert. So kann dieses Programm dazu verwendet werden, mit einer Codierung, Sprache oder Kultureinstellung (z.B. das Datumsformat wird so beeinflusst) zu arbeiten, die anders sind als der Standard oder die momentane Einstellung auf dem verwendeten Computer! Alle diese Einstellungen können selbstverständlich, leicht und schnell, an die momentanen Bedürfnisse angepasst werden. So macht es Sinn, FrendSoft TextEdi parallel zu anderen Text Editoren, welche andere Codierung, Sprache und Kultur Einstellungen haben, zur gleichen Zeit am selben PC zu verwenden. Die meisten Editoren bieten nicht die Möglichkeit so vieler Einstellungen und wenn, so starten sie doch mit den momentanen Einstellungen des Computers.

Diese Features bieten einen voll angepassten Editor mit einem besonderen Design, der durch die gemerkten Einstellungen von Sprache, Kultur und Codierung auch eine parallele Verwendung zu anderen Editoren am selben Computer als sinnvoll erscheinen lässt.

Ähnliche Themen:
Hilfe: Übersicht
Verwendung und Steuerelemente
Das Menü
Lizenzvereinbarung

© 2013-2014 FrendSoft.


4. Verwendung und Steuerelemente

TextEdi 4. Verwendung und Steuerelemente

Diese Software ist einfach und leicht zu verwenden.

Ähnliche Themen:
Hilfe: Übersicht
Originelle Features und Design
Das Menü
Lizenzvereinbarung

© 2013-2014 FrendSoft.


4.1 Das Menü

TextEdi 4.1 Das Menü

Das Menü von TextEdi sieht so aus:

Ein Klick auf "Umbruch" und dem ohne Zeilenumbruch angezeigten Text wird ein zur Weite des Fensters passender Zeilenumbruch hinzugefügt. Die weiteren Menüeinträge werden weiter unten erklärt.

Das Datei Menü

Dateien werden geöffnet und gespeichert in der bei Format -> Codierung gewählten Codierung.

Beim Drucken bitte bedenken, dass es in einer einfachen Textdatei nicht klar definierte Seiten gibt. Es werden Seiten geschätzt, doch abhängig von der Schriftgröße und Stil kann es zu unterschiedlichen Ergebnissen kommen. Die Druckvorschau zeigt die Aufteilung der Seiten, aber von hier kann man nur den Druck aller Seiten triggern. Man kann aber die Druckvorschau abbrechen und über den Menüpunkt Drucken einzelne Seiten ausdrucken. Im Menü Drucken kann man alle, einige oder die aktuelle (ein Abenteuer ohne Druckvorschau) Seite oder einen markierten Bereich des Dokumentes zum Drucken auswählen. Im Drucken Menü kann man auch den Drucker oder das Druckprogramm auswählen, die Seite einrichten und die Druckereinstellungen anpassen.

Das Bearbeiten Menü

Das Format des Datums- und Zeitstempels der eingefügt werden kann, hängt von der eingestellten Kultur ab und kann durch diese Einstellung angepasst werden!

Das Format Menü

Die ersten 3 Einträge im Format Menü beziehen sich auf Schrift und Hintergrund Formate, die letzten 3 auf PC Einstellungen die für das gestartete Programm FrendSoft TextEdi gelten.

ÜText Ausrichtung

ÜFarben

Man kann eine von 4 vordefinierten Text- und Hintergrund - Farbkombinationen wählen oder direkt die Schrift- und die Hintergrundfarbe auswählen.

ÜSchrift

Man kann entweder mit "Schrift auswählen" eine Schrift explizit mit den dazugehörigen Stil Einstellungen auswählen, oder vordefinierte Schrift Typen, Größen und Stile durch einen Klick wählen. Der Typ und die Größe können auch über ein Kombinationsfeld (Drop Down Liste) per Mausklick gewählt werden (siehe Kapitel "Schaltflächen"). Die Schriftgröße kann in +/- 0.5 Schritten durch Klicken auf entsprechende Schaltflächen (schnell und einfach) an momentane Bedürfnisse angepasst werden (siehe Kapitel "Schaltflächen").

ÜKultur

Wählbar sind aus einem Kombinationsfeld (Drop Down Liste) alle am Computer verfügbaren Kulturen. Die eingestellte Kultur wird gespeichert und beim nächsten Start von TextEdi wieder ausgewählt sein. So kann man TextEdi z.B. mit einer anderen Kultur - Einstellung verwenden, als der Standard an dem Computer. Die Kultur Einstellung ist unabhängig von der Spracheinstellung. Von der Kultur hängt das Format des Datums- und Zeitstempels ab, den man über "Bearbeiten -> Datum+Uhrzeit einfügen" in eine Datei einfügen kann. Wenn die Kultur an eine "rechts nach links" Sprache gebunden ist, dann wird "rechts nach links" für den Text Editor aktiviert. Genauso wenn eine entsprechende Sprache ausgewählt wird.

ÜCodierung

Man kann eine der am Computer verfügbaren Codierungen auswählen, wie Unicode, ANSI oder UTF-8, wie sichtbar. US-ASCII ist ein älterer Standard aber doch sehr geeignet für einfachen englischen Text und viele Anwendungen. Achtung: Wenn man die Codierung ändert, wird eine Datei in der gewählten Codierung geöffnet, angezeigt und gespeichert. Einige Zeichen werden nicht in jeder Codierung dargestellt werden, weil es keine Darstellung für den Zahlencode gibt. Wenn man dann den Text ändert indem man was reinschreibt, können entweder dieser Text oder die nicht angezeigten Zeichen verloren gehen. Also bitte die Codierung nur mit Vorsicht ändern. Wenn man die Codierung nicht kennt, bleibt man auf der sicheren Seite wenn man mit ANSI Codierung öffnet. Das ist auch der Defaultwert. Speichern sollte man allerdings lieber in Unicode, so können die meisten anderen Editoren den Text auch lesen. Man kann TextEdi auch dazu verwenden Dateien in einem Format zu öffnen und einem anderen zu speichern.

ÜSprache

Man kann aus einem Kombinationsfeld (Drop Down Liste) eine der am PC installierten Sprachen auswählen. Nur bereits installierte Sprachen können gewählt werden. Wenn zuerst gestartet, wird das Programm die aktuell am Computer eingestellte Sprache übernehmen. Diese oder eine andere, eingestellte, Sprache werden dann beim Beenden gespeichert. So kann man dieses Programm zum Editieren in einer bestimmten Sprache verwenden, auch wenn am PC eine andere Sprache eingestellt ist. Die Sprache kann man momentan aus dem Kombinationsfeld (Drop Down Liste) einfach und schnell anpassen.

Das Hilfe Menü

Ein Klick auf "Hilfe" öffnet diese Hilfedatei.

Ein Klick auf "Einstellungen Anzeigen" zeigt einige an dem Computer und für TextEdi geltenden Einstellungen.

Ähnliche Themen:
 Hilfe Übersicht
Originelle Features und Design
Verwendung und Steuerelemente
Die Schaltflächen
Die Tastenkombinationen
Lizenzvereinbarung

© 2013-2014 FrendSoft.


4.2 Die Schaltflächen

TextEdi 4.2 Die Schaltflächen

Das Schaltflächen Menü enthält die folgenden Elemente:

Von links nach rechts:

ÜDatei öffnen Schaltfläche

ÜKopieren

ÜAusschneiden

ÜEinfügen

ÜDatei speichern

ÜRückgängig

ÜWiederherstellen

ÜSetzen / Zurücksetzen Schrift fett

ÜSetzen / Zurücksetzen Schrift kursiv

ÜKombinationsfeld (Drop down Liste) Schrift auswählen

ÜTextBox Schriftgröße

In diese Box kann man die Größe manuell eintippen. Gültige Werte sind ganze Zahlen zwischen 3 und 99 oder zweistellige Dezimalzahlen zwischen 2,5 und 99,75. Das Format ist xx,yy wobei die letzten 2 Stellen und das Komma fehlen können.

ÜKombinationsfeld Schriftgröße

ÜSchaltflächen - und + um die Schriftgröße in 0,5 Schritten anzupassen (schnell und einfach, bis es passt).

ÜStarte diese Hilfe Schaltfläche

ÜNeue Datei Schaltfläche

ÜDatei Schließen Schaltfläche

Ähnliche Themen:
Verwendung und Steuerelemente
Das Menü

© 2013-2014 FrendSoft.


4.3 Die Tastenkombinationen

TextEdi 4.3 Die Tastenkombinationen

Die Tastenkombinationen sind entweder im Menü sichtbar oder werden sichtbar wenn man die "Alt" Taste drückt. Man kann bekannte Tastenkombinationen verwenden wie Strg+C für kopieren, Strg+V für einfügen und Strg+X für ausschneiden.

Tastenkombinationen gibt es und sind sichtbar in den Menüs "Datei" und "Bearbeiten", wie weiter unten gezeigt.

Ähnliche Themen:
Verwendung und Steuerelemente
Das Menü

© 2013-2014 FrendSoft.


5. Lizenzvereinbarung

TextEdi 5. Lizenzvereinbarung

Dieses ist eine rechtlich bindende Vereinbarung zwischen dem Anwender (User) (ab hier Lizenznehmer genannt) und FrendSoft (dem Lizenzgeber). Durch die Installation und Verwendung des Software Programms FrendSoft TextEdi 1.2 dessen Bestandteil diese Lizenzvereinbarung ist, oder irgendwelcher dazugehöriger oder damit verbundener Dokumente und Dateien (ab hier Software genannt), akzeptiert der Lizenznehmer die hier und weiter unten angegeben Bedingungen und Vereinbarungen .

Gewährung einer Lizenz: FrendSoft gewährt dem Lizenznehmer ein nicht-exklusives Recht die Software unter Berücksichtigung der hier angegebenen Bedingungen zu verwenden.

Freeware: Diese Version von TextEdi (TextEdi 1.2) ist Freeware. Die Software kann ohne jede Zahlung verwendet werden. Dieser Editor soll auch planmäßig Freeware bleiben. Wenn der Lizenznehmer glaubt, dass die Programmierer eine monetäre Aufmerksamkeit verdient haben, steht es ihm frei diese zu leisten. Dazu näheres auf "Kontakt und Verdienste". Oder direkt durch Überweisung auf folgendes Konto: IBAN DE58502205000008416919, BIC BOFSDEF1XXX Bank Of Scotland!

Gültigkeit und Versionen: Diese Übereinkunft ist nur für die ausgelieferte Version gültig. Jede andere Version wird ihre eigne Lizenzvereinbarung beinhalten.

Kopien: Der Lizenznehmer kann eine unlimitierte Anzahl von Kopien anfertigen.

Weitergabe an Dritte: Will der Lizenznehmer die Software an dritte zur Verwendung weitergeben, darf er das nur, wenn diese Lizenzvereinbarung zusammen mit der Software weitergegeben und darauf aufmerksam gemacht wird.. Der Lizenznehmer darf die Software nicht modifizieren, sondern nur wie ausgeliefert verwenden. Es ist nicht erlaubt modifizierte Software an andere weiterzureichen. Es ist nicht erlaubt diese Software gegen Geld oder andere Werte weiterzureichen, sondern nur kostenlos, als Freeware. Lieber Lizenznehmer bitte dritten lieber die Adresse von wo man diese Software herunterladen kann angeben, statt die Software selbst weiterzugeben.

Eigentümer des Quellcodes: Der Quellcode dieser Software und alle damit verbundenen Dateien bleiben Eigentum von FrendSoft, welches sich das Eigentumsrecht über den Quellcode, alle Kopien dieses Quellcodes, alle Modifikationen oder Teilen die anderswo mitverwendet werden vorbehält. Es ist verboten diese Software oder den Quellcode in anderen Projekten oder zusammen mit anderem Quellcode oder in anderen Programmen ohne die ausdrückliche Erlaubnis von FrendSoft, die man erfragen kann, zu verwenden.

Gewährleistung und Haftung: FrendSoft haftet für keine direkten oder impliziten Schäden die durch diese Software oder deren Verwendung entstehen können. FrendSoft gewährt auch keine Garantie, dass diese Software für irgendeinen Zweck verwendet werden kann oder irgendeinen Zweck, egal welchen, erfüllt.

Ähnliche Themen:
Hilfe Übersicht
Originelle Features und Design
Das Menü

© 2013-2014 FrendSoft.


6. Kontakt und Verdienste

TextEdi 6. Kontakt und Verdienste

previous

Lieber Benutzer oder Lizenznehmer

Kontakt zu FrendSoft ist über eine der Websites: http://www.frendsoft.com oder http://www.frendsoft.de möglich.

Für die Realisierung dieses Programms haben SW Experten und Programmierer beigetragen, die unter dem Namen Norbe erscheinen möchten.

Man kann uns auch direkt via E-Mail: contact@frendsoft.com erreichen. Es steh jedem frei eine Spende an uns zu senden:

Bank Account: IBAN DE58502205000008416919, BIC BOFSDEF1XXX Bank Of Scotland!

Je mehr man spendet, desto besser wird das Ergebnis sein. Wir planen viele nützliche Programme in der Zukunft zu erstellen.